
Chapter 3

Create an arrow with Draw, Offset, Snap, and Join

The drawing below shows an arrow that a machinist had to
make. While you may not have to cut arrows, the techniques
that you will learn in this example will apply to other shapes.

There are different ways to create the arrow.
This chapter uses the Draw Menu and offsets.
The Draw Menu was briefly described in Chapter
1, page 2.

Step 1) Draw the 1.22 radius arc.

Bring up the Draw menu and pick the Arc
option, either by clicking the Draw button with
the mouse or by pressing DA. The arc drawing
fields will appear on the right side of the screen.
For the sake of simplicity, set the center of the
arc to X0,Y0.

According to the specs, the arc’s radius is
1.22, and it has a sweep of 60°, so fill in those
two values, as seen in Figure 3-1.

You have just specified enough information
to create an arc, so MillWrite will draw a dotted
arc to show you what the arc looks like.

Notice that MillWrite fills in the start and
end coordinates for you, but the color for those
coordinates is different than the color for the
values that you entered. MillWrite fills in the
empty fields in case you want to know what they
are, and the values are displayed in a different
color to show you that MillWrite, not you,
entered the values.

The starting angle for this arc is 0°, and this
arc is counter-clockwise, but by coincidence
those are MillWrite’s defaults for arcs, so you
don’t have to specify those values. If the arc had
started at some other angle, then you would
have to specify that angle.

This arc is complete, so click the OK button.

Step 2) Draw the 1.59 radius arc.

Notice that the data fields are blank except
for the start coordinates, as seen in Figure 3.2.
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Figure 3-1

Tip: MillWrite lets you move X0,Y0 easily, so
when you want to draw a new shape, it
is often easiest to move X0,Y0 to the
center or a corner of the new item you
are making. After you create the items
you can move X0,Y0 back to where it
should be.
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MillWrite filled in the start coordinates with the end
point of the previous arc in case you want this new
arc to continue from the previous arc. However, the
arc you will now create does not continue from the
previous arc, so ignore the values you see. You do
not need to clear those values.

This arc has the same center point of X0, Y0, the
same sweep of 60°, and its radius is 1.59. Fill in those
values, and you should see a dotted arc. Also, notice
that MillWrite changed the start coordinates and
filled in the end coordinates, as seen in Figure 3-3.

Click the OK button to accept the arc, and then
click either the OK or Cancel button to quit drawing
arcs, or press the k key.

Step 3) Draw the arrow’s tail.

You have drawn two arcs. Each arc has two
“nodes” and a center point. Now you have to draw a
line from a node on one arc to a node on the other
arc, as seen in Figure 3-4. You want this line to be
exactly on the nodes, rather than merely close to
them.

Bring up the Draw menu and pick the Line
option (the keyboard shortcut is DL). You could
figure out from the specs what the start and end
points of the line should be, and then you could type
them into the data entry fields, but there is an easier
way. Click on the word Start, as seen in Figure 3-4.
The word will start blinking in a blue color. Then
move the mouse into the drawing and put it on the
node of one of the arcs, such as the node pointed to
by the arrow in Figure 3-4. Notice that the mouse
icon will change to show the word “Start Node”
when it is on the node, as seen in Figure 3-5. If you
see the word “Link” instead, that means you do not
have the mouse on the node, in which case if you
click the mouse button, you will get the wrong X-Y
coordinates. The mouse icon must be displaying
“Node”, “Start Node”, or “End Node” in order for
you to be guaranteed that you are specifying the X-Y
coordinate of the node.

After you see the word “Node” in the mouse
icon, click the left button. MillWrite will fill in the
Start X and Y data fields with the coordinates of the
node, as seen in Figure 3-5.

If you click the wrong node, or if the mouse was
not exactly on the node when you clicked it, just put
the mouse on the correct node and click it again. It
doesn’t hurt anything to click it more than once.
Rather, MillWrite just assumes you made a mistake
with the previous click.

After you set the Start X and Y coordinates to one
of the nodes (it doesn’t matter which node), click the
label End Point, as seen in Figure 3-6. The label will
start blinking in blue. Then click the mouse on the
other node of the other arc, as seen in Figure 3-6.
MillWrite will draw a dotted line to show you what
you are specifying.

The line is now complete, and MillWrite will
show you the angle and length of the line in a
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different color. If you specified this line correctly,
you will see a length of .37 and an angle of either 0°
or 180° (the angle depends on which node you
picked to be the start of the line). You are finished
with this line, so click OK to let MillWrite know you
want to keep it.

Step 4) Draw one of the .09 lines.

The line drawing function should still be
showing, with most values empty. Referring to
Figure 3-7, click the label Start. Then move the
mouse to the other end of the large arc and click its
node. This will set the start for the .09 line, but what
do click to set the end of this line?

There is nothing to click to set the end node.
However, the specs show the line has a length of
.09, so move the cursor to the Length field and
enter .09. MillWrite will draw a dotted horizontal
line, and display and the coordinates of the end
point. However, that is not the end point you want,
so ignore it. MillWrite is assuming the line has an
angle of 0° since you didn’t specify an angle.

According to the specs, this line is 60°
counter-clockwise from the X axis. Since CAD

systems measure angles counter-clockwise from the
X axis, that means this line has an angle of 60°. So
move the cursor bar down to the Angle field and
enter 60. You will now see MillWrite display the
correct line and end point for it (Figure 3-8). You are
finished with this line, so click OK.

Step 5) Draw the other .09 line.

This is similar to step 4. Click the Start label and
then click the other node on small, inner arc.
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The only difficulty with this line is figuring out
the angle MillWrite needs. MillWrite measures the
angle of lines from the start of the line to its end.
Therefore, this line will be in the opposite direction
of the other line, which means this line is 180° from
the other line. Since the other line has an angle of
60°, this line has an angle of 60° plus 180°, which is
240°. So enter 240 in the angle field. You screen
should look like that in Figure 3-9. Then click OK.

Step 6) Draw construction lines

You cannot use the Draw Line function to
make the arrow head because the specs don’t
provide the length, angle, or end points for the
lines. The only info the specs provide is that the tip
of the arrow is .5 inches from those two .09 inch
lines. So lets draw construction lines that are .5
inches from those two .09 inch lines. The easiest
way to do this is to use the Offset command to
make .5 inch offsets of each of the two .09 inch
lines.

If the Draw Line function is still active, cancel it
and move the mouse back into the drawing. Then
start the Offset function, which you can find in the
Edit menu, and the Main menu (which provides
access to the Edit menu). Or, as the message in the
lower right corner of the screen will remind you,
just press the O key.

The screen changes when the Offset function
starts (Figure 3-10). There is a data entry field on
the screen where you specify the offset value, but
you don’t have to first click the field. MillWrite
knows that if you type a value, you are specifying
the offset. So just type .5 and press n.

Since you will be offsetting an individual line, it
doesn’t matter whether you pick a CAM or CAD

offset, nor does it matter if you pick OFFSET

INDIVIDUAL LINKS or OFFSET ENTIRE POLYLINES.
No matter what you set these options to, the offset
of an individual line will always be just another
individual line. These options are important only
when you offset polylines.

Before you continue, if you cannot clearly see
the .09 lines, press the r or s keys to zoom
in or out, and/or the keyboard arrow keys to move
the image, to make the lines you are going to offset
more easily visible.

Now touch the mouse to one of the .09 inch
lines. The mouse icon will change to show the
words “Fixed Offset”, (Figure 3-11) when you
correctly put the mouse on the line. Then click the
left mouse button.

The message on the top of the screen will then
change. You will be asked to click on the side of the
line you want to offset. All you have to do is click
somewhere off to the left side of the line. MillWrite
will then create the offset.

Now offset the other .09 line by clicking on it,
and then clicking somewhere to its left. The screen
should then look like Figure 3-12. You are finished
offsetting both lines, so click the Done button in the
upper left corner, or press the k key.
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Step 7) Draw using Object Snap

Those two offsets are all you need to
complete this arrow. The tip of the arrow is at
the midpoint of those offset lines. So now you
draw a line to that midpoint.

Click the Draw menu button and then pick
the Line function. Click the label Start, and then
click the end node of one of the .09 inch lines,
as seen in Figure 3-13.

Now the situation gets tricky. The location
you want for the end of the line doesn’t have a
node at that location, so you cannot click a
node. The solution is to use Object Snap.

Notice that bottom right corner of the screen
reminds you that you can click the right mouse
button for the Object Snap functions. So click
the right mouse button on the label End point.
As seen in Figure 3-14, this turns the End point
label blue, and the Object Snap menu appears
near the center of the screen. Pick the Midpoint
option.

The message at the top of the screen will
change (Figure 3-15). You will be asked you pick
a link or two points. In this case you will pick
two points.

Move the mouse to the start node of one of
the construction lines. As seen in Figure 3-15,
the mouse icon changes to show the word Start
Node when you have it on the start node. Click
the left mouse button when you see Start Node.

The message at the top of the screen will
then change to ask you to pick the 2nd point
(Figure 3-16). Touch the start node of the other
construction line with the mouse. You should
see the mouse icon change to show “Start
Node”, as seen in Figure 3-16. Then click the left
mouse button. You just specified the two points
that you want MillWrite to calculate the
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midpoint of. MillWrite will then draw the line to that midpoint.
Note that you could have picked the two end nodes of

those construction lines rather than the two start nodes. But
you couldn’t pick the start node of one line and the end node
of the other because that would have created the wrong
midpoint.

Step 8) Complete the arrow head

Drawing the last line of the arrow is easy; the start node of
the line is already set for you, so all you have to do is click the
End point label and then click the end node of the other .09
line. Click OK when finished, and then cancel the line drawing.

Step 9) Delete the construction lines

Deleting a few individual items is easy; just touch one of
them with the mouse and press the q key.

Another way is to touch any geometry with the mouse, click
the right mouse button for the Node Menu, and pick the
Delete Item option. In the case of individual lines, you could
also pick Delete Node or Delete Link; all three functions will
delete an individual line. After setting the mouse to one of the
Delete functions, just click the left mouse button on each item.

If you have a lot of items to delete, it is easier to select all of
them by drawing a window around them. This causes MillWrite
to switch to the Selection mode. Then you can select more
items, or un-select items that you accidently selected. When
finished selecting items, click the Delete button.

Step 10) Put a line on top of another

The arrow is complete, but it consists of seven individual
lines and arcs. As the next chapter will explain, it is usually best
to use one polyline rather than individual lines and arcs.

MillWrite will automatically join all seven lines and arcs into
one polyline if you set any of the lines or arcs to a CAM usage of
“Spiral Pocket” or “Contour”, but sometimes you will want to
join items together by yourself, so you need to
know how to do it.

The lines and arcs that make up arrow are
easy to join together because all the lines and
arcs form a closed loop without any overlapping
or duplicate lines. Also, there is no gap between
the lines and arcs

The lines and arcs in this arrow would be
more difficult to join together if you drew
unnecessary lines on top of other lines, or if you
had gaps between them. If you wonder why
anybody would put unnecessary lines on top of
other lines, just look at some DXF files that
engineers pass to machinists. The engineers
often lack an understanding of what a machinist
needs, so when they create drawings they
sometimes have lines on top of lines. They also
sometimes have gaps between the items.

Furthermore, you may accidently put lines
on top of other lines when you get distracted or
confused. Therefore, you should know how to
recognize this particular problem. So, let’s create
a line on top of one of the other lines.

From the Draw menu, pick the Line function, and then set
the start and end of this new line to the same start and end of
one of the lines in the drawing. To do that, just click the label
Start, and when you see it blinking in blue move the mouse
into the drawing and click a node of the line that is identified in
Figure 3-18. Then click the label End Point, and when you see
it blinking in blue move the mouse into the drawing and click
the other node of that same line. Then click OK, and cancel the
line drawing function. You now have a line on top of another
line, but you will not be able to see it by looking at the drawing.

Step 11) Use z to check for duplicate items

If you suspect a line (or arc) is on top of another line (or arc),
you can quickly check for it by touching it with the mouse and
looking at the lower right corner of the screen to see what the
ID number of that item is, as in Figure 3-17. Then press the
z or ‘ key, which, as mentioned in Chapter 1, will force
MillWrite to search for another item at that location. If there is a
duplicate item, you will see the ID number change. You may
also see the parameters on the right side of the screen change, if
the other item has different parameters.

If you press the z or ‘ key a third time and find a third
ID number, that means there are three items on top of each
other.

Step 12) Join items into one Polyline

There are two ways to start the “Join items” function:

§ Bring up the Node Menu and pick the Join Items function.
Then click any of the lines or arcs that you want to join to
other items.

§ Touch one of the lines or arcs with the mouse and press J

for the Join function, as the prompt at the bottom right
corner reminds you (Figure 3-17. )
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Pretend that you don’t know there are two lines on top of
each other in the arrow. Touch the line of the arrow head (the
dotted line in Figure 3-18) with the mouse and press J for the
Join function. The screen will change (Figure 3-18). The line
you touched will be the item that the others are joined to. As
you join items to it, the others become dotted also so that you
can follow what is happening.

You have several options with the Join function, as you can
see at the top of the screen. One option is OK To Mix Layers.
This option is useful for drawing that have items on different
layers. If you un-check this box, MillWrite will not join items
unless they are both on the same layer.

If the OK To Mix Layers button is checked, you can
restrict which layers can be mixed by entering the layer
number in the two data fields below it. Since the layers are
numbered, any item on a layer that is numerically between

the Process From layer and the To layer will be considered
in the joining process.

Another option is Max Gap. This option is for drawings in
which the items have gaps between them. In such a case, you
can set a max gap, and if MillWrite finds two items are closer
together than that gap, it will ignore the gap and join the items
together.

However, these options don’t apply to this arrow because
all your lines and arcs are on the same layer, and they all touch
without gaps. So you can ignore the options.

Now look at the mouse icons in the lower left corner
(Figure 3-18). The functions are:

Left button: Join if Touching.

If you click a line or arc with the left button,
MillWrite will join it only if it is touching end to
end with the arc. Items not touching are ignored.

Middle button: Join as is

Clicking a line or arc with the middle button
will join an item regardless of whether or not it is
touching. If it is not touching, it becomes joined,
but there will be a gap between it and the other
links in the polyline chain. A situation where you
would join items that do not touch is when you
create logos or letters, or if you are creating the
outline of the state of Michigan. Michigan has
two separate sections that you might want to join
so that they remain together.

Right button: Join with Line

Clicking a line or arc with the right button
will join items regardless of whether or not they
touch. However, this button will create a line to
connect them if they do not touch.

Now let’s join the items.

The line that is dotted in Figure 3-18 is the
line that the others will be joined to. To join
items to it, you could click the left mouse button
on each line and arc. As seen in Figure 3-18, the
mouse icon changes to “Join” when you touch
an item. But this is a slow method. A better
method is to click one of the three functions at
the top of the screen and let MillWrite figure out
which items are touching end to end.

The three types of joining functions are:

Join From Both Ends And Quit

This function will join all items touching
either the start or end node. When MillWrite
cannot find any more items touching end to end,
it quits the join function and you return to the
drawing.
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Follow Path From Its End

This function joins items only from the end
node. Any items touching the start node are
ignored.

Join But Verify Each

This joins items from both the start and end
node, but MillWrite asks for your approval before
joining the items together. This function is useful
when you want complete control over the joining
process, or when you want to stop the process at a
certain location.

For this simple example, click either the Join
from both ends or the Follow path function (the
keyboard shortcuts are B and F, as the message on
the right side of the screen reminds you). Both
functions will end up doing the exact same thing in
this case because the arrow makes a closed loop.

However, there are two lines on top of each
other, so when MillWrite encounters those two
lines, it will not be sure which of them to join to the
others. The screen will change, as seen in Figure
3-19. This User’s Manual cannot show this, but
MillWrite will cause the line to blink to show you
which line it is asking you about. MillWrite wants to
know if you want this line joined to the others.

At the top of the screen MillWrite is telling you
that it found two items. If you want the blinking
item to be joined to the others, press the n key. If
you want to see the other item MillWrite found,
press z or ‘. However, in this case, if you
press the z you will see the same line blink
because the two lines are exactly on top of each
other. The only way you would realize that
MillWrite is now blinking the other line is to look at
the top of the screen. You will notice that the ID
number of the blinking line has changed.

Now you see a symptom of lines on top of lines.
To summarize, MillWrite will tell you that you have
to make a choice between several items, but it will
appear as if the same item blinks over and over.

Now pick one of the blinking lines to join to the
others. MillWrite will join that line, and then it
continues looking for items to join together.
However, MillWrite will now notice that it has two
possible paths to take; it can join the arc or it can
join that unwanted line that you didn’t want the
previous time. So you will again be asked to make a
decision between two items. However, this time it
will be more obvious as to which item is which.
When you press the z you will see the arc blink,
and when you press it again you will see the line
blink.

So a further annoyance of lines on top of each
other is that MillWrite will encounter them twice, so
you have to reject them two times.

The fastest way to join items

If your drawing is designed properly (ie, if it doesn’t contain
duplicate items) you can click the Edit Menu button, and then
pick Make Changes To Entire Drawing, and then pick Join
Items. MillWrite will then combine all items that touch each
other. This will also give you the option to join items on a layer
by layer basis, also.
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